Hailo Network IP Ltd | What phone do I need?

Help Center

What phone do I need?

Last Updated: Oct 02, 2013 10:29PM BST

Hailo works on iPhone and Android smartphones. Specifically, any Android phone that runs on version 2.2 or higher and iPhone models 4 or later. For iPhone make sure you are running iOS 4.3 or above. Hailo works best on the most up-to-date phone software, so please check you have the most recent versions installed for the best Hailo experience. 

Was this answer helpful?